0

After uploading the 4.7.21 plugin the CiviCRM admin pages loaded ok with the status at bottom indicating new version and of course with a red 'System Status' warning. On clicking this to get to the status page to update db etc, got this error: Uncaught exception: You have requested a non-existent service "asset_builder".

Tried installing clean copy again. Same result. Resolved issue by manually entering the upgrade page url. This brought up expected option to upgrade db. All well after this. https://xxx/wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1

Question: is this just our installation or have others had same behaviour, and did this fix resolve?

  • After the upgrade, if accessing to System Status page again, it continues giving an error? – Francesc Bassas i Bullich Jul 7 '17 at 10:35
  • I experienced something similar, except I cannot get the system status page to populate at all. I had run the upgrade script by entering its URL manually, and it seemed to work on the second try except for a missing indices error -- but now I can't get my system status information. Posted a question here – Prónay Jul 7 '17 at 18:31
1
  • Need to give time for the status page content to load after initial view – Eric Booth Jul 10 '17 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.