Trying to implement the solution that worked when I got the missing indices error after the 4.7.20 update, but can't hit the Update button because System Status page isn't populating with anything. Haven't found a cause or solution for the empty System Status page. So I'm running 4.7.21 -- presumably with the missing indices error, and no way to fix it.


  • Same issue here... anyone find a solution yet?
    – themak
    Commented Jul 11, 2017 at 19:47
  • Just updated to 4.7.22, and no missing indices errors ... yet. System status page is loading fine as well.
    – Prónay
    Commented Jul 18, 2017 at 1:32

1 Answer 1


This sounds similar to Status page angular load error and i will paste my answer here, though I think your 'question' is the wrong issue, ie this is angular issue, not missing indices issue.

We had one site that had 'lost' all it angular pages, eg CiviMail and System Status.

In our case the angular cache files were returning 404 on the New Mailing page. (and 'inspector' was showing a lot of red angular errors)

It was building the cache files in sites/default/files/civicrm/images, but then searching for them in sites/default/files/civicrm/persist/contribute

The issue here was a mismatch between the resource url setting for Image Upload URL and the directory setting for Image Directory. Strangely (!!) these folders are being used for caching of angular files.

  • Thank you, Pete -- I just saw your answer and was about to look at resource URL settings, when system status finally populated. I hadn't changed anything yet -- it just suddenly worked. No idea why.
    – Prónay
    Commented Jul 7, 2017 at 20:18
  • 1
    Had a similar issue. Needed to refresh System Status 4 times before I got content
    – Codedogs
    Commented Jul 11, 2017 at 3:13
  • 1
    interesting - so you guys both got it back via patience +/- cache clearing - we have started a JIRA issue so that Upgrade includes clearing civi caches, which might improve such situations.
    – petednz - fuzion
    Commented Jul 11, 2017 at 4:02
  • Also getting this error: Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/site/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/VersionCheck.php on line 429 Warning: file_get_contents(latest.civicrm.org/stable.php?format=json): failed to open stream: no suitable wrapper could be found in home/site/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/VersionCheck.php on line 429
    – themak
    Commented Jul 11, 2017 at 20:25
  • 1
    Hmmm, empty status page, as well, after upgrade CiviCRM 4.7.20 --> .22; I didn't have any issues with Angular, and repeated refreshes of the status page did not fix things either. Per Chat channel discussion with KCristiano, filling in the absolute paths for [civicrm.root] and [civicrm.files] on the Resource URL page did fix the issue for me. Config: Ubuntu 14.04.5 / LAMP on AWS t2 micro with WordPress 4.8.0 as CMS.
    – dvhirst
    Commented Jul 28, 2017 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.