2

After installing the 4.7.21 upgrade my D6 site shows as upgraded and Civi appears to run correctly. However when I run the upgrade script I get error: Sorry but we are not able to provide this at the moment. DB Error: no such field""

If I delve into the error I find: [nativecode=1054 ** Unknown column 'civicrm_custom_group.is_public' in 'field list']"]

Can anyone guide me how to fix this?

  • That sounds familiar - do you have views enabled? Are you using drush? – user4278 Jul 10 '17 at 22:33
3

We have had to create this field in the db in several sites we have upgraded. Not sure why the upgrade script is failing to do this correctly

Fuzion have provided a patch for this to avoid the problem for future folks doing upgrades

| improve this answer | |
3

SOLVED: For good measure here is a repeat of the above comment.

I was able to successfully install the upgrade to 4.7.21 on Drupal 6 after applying the patch mentioned above, and after disabling Views, CTools and Webform (and all related/dependant modules).

The upgrade then ran smoothly without any problems.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.