1

Facing this warning Timestamps reported by MySQL (eg "2017-07-20 13:48") and PHP (eg "2017-07-20 08:18" ) are mismatched.

While MySql time matches with my local time. PHP is running 5:30 hrs less. My timezone is UTC+5:30 hrs.

Tried below options,

  1. changing the setting in UI ( WAMP -> PHP settings) and also in PHP.ini.
  2. Wordpress settings

Didnt seem to work. What else I need to try?

3

Try setting your preferred timezone in civicrm.settings.php and/or wp-config.php?

ini_set('date.timezone', 'Asia/Calcutta');

You might want to adapt the timezone you set as appropriate to your MySQL server.

mysql -e 'SELECT @@system_time_zone;'

I believe India does not observe daylight savings? For that and similar reasons it's probably better to match the timezones in both systems. If MySQL is set to UTC offset, use that for PHP, and if MySQL is set to a regional timezone, follow suit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.