4

We started using the CiviVolunteer extension with success. However, after we upgraded to the security release 4.7.21 some of the CiviVolunteer functions do not work. Or they cannot be accessed from the navigation menu.

We cannot access the following functions; - New Volunteer Project - Manage Volunteer Projects - Search for Volunteer Opportunities

In addition, the CiviVolunteer menu items cannot be seen on the Navigation Menu editor (Administration > Custom Data and Screens > Navigation Menu)

  • 1
    In case you haven't seen it, a beta release and patch have been prepared. We're requesting that folks who have been affected by this problem provide feedback before the fix is released more widely. – universalhandle Aug 1 '17 at 15:22
2

Just for context - the security issue that caused CiviVolunteer to break was https://issues.civicrm.org/jira/browse/CRM-20243 - we upgraded to a secure version of Angular. Unfortunately our policy with security updates is not to give people advance notice - on the basis that it alerts the black hats more quickly than the white hats - so Gingko were not pre-warned there was a security release going out.

The catch 22 of security releases is that they are the most essential and the most risky updates. Perhaps the risk of regressions when people don't know they are coming is greater than that of the black hats. Although people on the security channel didn't seem to test this either

2

Ron. This is a known issue. CiviCRM made some changes to its Angular (a JavaScript library) integration that CiviVolunteer needs to catch up with.

CiviVolunteer is maintained by an independent consultancy, Ginkgo Street Labs. We would like to resolve this problem as soon as possible, but we have a full slate of projects that, as a small business, we need to prioritize ahead of unfunded work. If your organization is able to contribute developer hours or funds toward resolution of this problem, please contact us.

1

Ron,

They released another update 4.7.22. Here are details on the fixes in this version: https://github.com/civicrm/civicrm-core/blob/4.7.22/release-notes/4.7.22.md#bugs

I'm not sure if it will fix the CiviVolunteer issues, but maybe you want to give it a shot.

1

A new version of CiviVolunteer has just been released that addresses this issue. Users running CiviCRM 4.7.21 and higher should upgrade. Details are here:

http://ginkgostreet.com/content/announcing-civivolunteer-222-release-0

Users of CiviCRM 4.7.20 and prior SHOULD NOT UPGRADE CiviVolunteer past 4.6-2.2.1. The changes to CiviVolunteer that make it compatible with CiviCRM 4.7.21 and higher are incompatible with earlier releases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.