1

Not a question so much as an answer. After installing Civi 4.7.6 under WP, I tried running all scheduled jobs using: easyCron, Cron (through CPanel) with wp-cli, cron.php, and from commandline curl, php...wp-cli, php...cron.php. Finally I was successful running all jobs using URL 'https://mysite.com/wp-content/plugins/civicrm/civicrm/bin/cron.php?user=adminuser&password=mypwd&key=sitekeyfromcivicrmsettings I had to move civicrm.settings.php to wp-content/plugins/civicrm - the install had placed it under wp-content/plugins/uploads/civicrm. Some errors I got when trying to run as an actual cron job (putting it into crontab) referred to 'not finding default/civicrm.settings..' which sounds to me like a Drupal-oriented message, since that's where Drupal civicrm.settings.php go but not Wordpress. HTH someone else.

1

I had verified by running php -v (after shelling in) that (cli) was supposedly enabled but I could not submit a cron job using wp-cli. I tried using curl, but got "Protocol http or https not supported or disabled in libcurl". I didn't fare well with easyCron - I felt uneasy supplying my pswd there; but after seeing jobs tagged with 200 ('succeeded') in logs, my installation didn't reflect that. One important bit of information - this site isn't live yet, so I am pointing to it via my Hosts file. But I have to verify that stuff works BEFORE go-live.
So, from where I stand, using the URL method seemed to be the one workable method. (also, I could run it locally and debug it!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.