1

I'm running CiviCRM on WPEngine. It works real fast and seems to be working well otherwise. No error logs occur on production side. The staging environment does not work, I get a 500 error when I try to access Civi there.

I also tried to clone the install and create a testing area but that also gives the same issue.

I am getting this error.

Does anyone know how this would be resolved? Thanks!

[Thu Jul 27 14:02:29.745288 2017] [:error] [pid 26200] [client 88.87.189.26:25979] PHP Fatal error: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/nas/content/live/lpiacrm/wp-content/plugins/civicrm/civicrm/:/nas/content/live/lpiacrm/wp-content/plugins/civicrm/civicrm//packages:.:/usr/share/php') in /nas/content/live/lpiacrmtest/wp-content/uploads/civicrm/civicrm.settings.php on line 467, referer: https://lpiacrmtest.wpengine.com/wp-admin/

  • The above error code was on the cloned install. Below is an error for the staging site [Wed Jul 26 03:14:25.074706 2017] [:error] [pid 5364] [client 184.97.200.126:45698] [wpengine] failed to read config – Andy Burns Jul 27 '17 at 14:12
1

Your error message has a path with the word "live" in it (/nas/content/live/etc) which suggests that the civicrm_root value hasn't been changed on the test site.

civicrm.settings.php is the equivalent of wp-config.php - you need a separate version of this file for your live and test sites. Please review your test site's civicrm.settings.php - not just to fix the civicrm_root but also the database settings, base URL, etc.

  • As an aside - I'm glad to hear that CiviCRM is running OK on WPEngine! Last time I tried they had a lot of the limitations that I associate with PaaS that made running Civi difficult. – Jon G - Megaphone Tech Jul 27 '17 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.