2

On a 100% fresh Drupal 7.56/CiviCRM 4.7.22 install, after entering all the db info in the CiviCRM installer and clicking "Check Requirements and Install CiviCRM", I get the following error:

Fatal error: Class 'Symfony\Component\DependencyInjection\ContainerBuilder' not found in ... /sites/all/modules/civicrm/Civi/Core/Container.php on line 104

I also got this same error when trying to perform an upgrade of an existing CiviCRM installation from an older version (4.4.5) to the latest. I thought a fresh install might be the fix, but apparently not.

I've searched documentation and Google for this error and found no real information on what could be causing it. All the server/database requirements are in place as far as I can tell, so I'm not sure if this is something any others have experienced? If anyone can shed any light on this error, it would be much appreciated. Thank you.

  • Could you maybe add some info about how you installed it, was it using civibuild or the tarballs from civicrm.org/download? – mickadoo Aug 6 '17 at 8:19
0

I had this in an upgrade scenario when I forgot to clear my templates_c folder. Clearing that folder solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.