2

I have drupal running perfectly; with mysql support. But CiviCRM still giving me this error - “MySQL support not included in PHP.”

My PHP version is 5.6.31, as indicated in the screenshot below.

enter image description here

  • Which civi version are you trying to install? – jitendra - fuzion Aug 2 '17 at 12:20
  • Civi version is 4.7.22 – Jangid Aug 2 '17 at 13:12
3

Your drupal may be using a different mysql driver. CiviCRM recently migrated to requiring mysqli. See https://civicrm.org/blog/totten/psa-please-verify-php-extension-mysqli for more details.

  • In which version of civi they have migrated to mysqli? – Jangid Aug 2 '17 at 13:13
  • I recompiled php with --with-mysqli and it is working now. – Jangid Aug 2 '17 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.