After updating to 4.7.23 from 4.7.20, I can now use the CKeditor Configuration and the changes are saved based on the changes made at https://issues.civicrm.org/jira/browse/CRM-19303, but the wysiwyg doesn't show up. The Drupal log error message reports "page not found" and that it is looking for


when I believe it should be looking for


I'm not sure how to go about changing this. Everything else seems to be working correctly as my Resource URL's and Upload Directories look correct.

Thanks in advance


After some further sleuthing I discovered my production site running 4.7.20 reports: [civicrm.root] https://focusdc.org/sites/focusdc.org/modules/civicrm/

whilte my staging server running 4.7.23 reports: [civicrm.root] http://staging.focusdc.org/sites/focus/sites/focusdc.org/modules/civicrm/

They have identical civicrm.settings.php outside of the one having SSL and one referencing "staging".

Did the $civicrm_root settings change in civicrm.settings.php between 4.7.20 and 4.7.23? Any other thoughts?

  • To further clarify, I previously was able to get the wysiwyg working (although without the configuration) in 4.7.20 by applying the patch here. github.com/civicrm/civicrm-core/pull/9458/files
    – jansmath3
    Aug 8, 2017 at 19:37
  • Can you re-check your resource URL setting and clear all caches?
    – Coleman
    Aug 11, 2017 at 14:00
  • Thanks for the help Coleman. I've tried all possible combinations I could think of using absolute URLs and URL variables and nothing works. Still redirecting to the wrong subdirectories. The extra "/sites/focus" seems to be the culprit.
    – jansmath3
    Aug 15, 2017 at 19:44

2 Answers 2


You should be able to fix this by defining the CIVICRM_CMSDIR constant. Since you're using multi-site, you'll need to define that on a per-site basis.

  • Thanks Jon for the reply. I've tried all angles of implementing the CIVICRM_CMSDIR constant and it does help correct the cms directory root, which will probably alleviate some pain in the future. However, it doesn't fix the extra "/sites/focus" when ckeditor is loading.
    – jansmath3
    Aug 16, 2017 at 17:10
  • Do you have a symlink somewhere in your $civicrm_root? Aug 16, 2017 at 17:19
  • I do have a symlink from the /var/lib/mysql to the location of mysql databases. Could that cause it?
    – jansmath3
    Aug 16, 2017 at 18:21

Thanks Jon G, for steering me in the right direction and hopefully this might help someone down the line.

I probably wasn't particularly clear in my description in that I run a Drupal multisite but CiviCRM is still running under it's original single site (although this is bringing me a step closer to having all the sites run CiviCRM especially for webform integration).

Accordingly, I was still hosting CiviCRM in the 'subsite'/modules directory. When I moved the module into the /all/modules and changed the $civicrm_root any inconsistencies in the Directories and URL Resources corrected themselves.

Now the CKEditor Configuration works!

  • Feel free to mark your own answer as "Accepted"; this will help future folks. Thanks for reporting back! Aug 17, 2017 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.