3

Using D7 civiCRM 4.7.22. The "save" button is greyed out in the back end new contribution form (and the "confirm contribution" button in online forms) after upgrade to 4.7.22. This happens as soon as I select a payment method other than default in the back end. e.g. the default is "check", if I select "cash" then the save button is greyed out. This also happens in the online form (no payment method is available for selection, but if the default isn't set as "credit card" then the "confirm contribution" button is greyed out).

This was all working as expected in 4.6 before upgrade.

Thanks for your thoughts!

4

This is likely to be a resource URL issue - the way these fields are calculated has changed in CiviCRM 4.7.

Please look at Administer menu » System Settings » Resource URLs and Administer menu » System Settings » Directories. Please ensure that both of these look correct. Note that you might see a token (e.g. [cms.root]) as part of your URLs and paths - you can press the little question mark in the blue circle at the top of the page to see what those tokens expand to.

[See comments below for my final fix which was to to go to system settings -> clean up caches and update paths - JR]

  • k. I updated my resource urls with the new tokens. All the file paths look as they should. Still greyed out. Is there anything in the civicrm.settings.php that needs to be updated? – John Richardson Aug 9 '17 at 19:20
  • Just to be clear, I am still getting the grey out when I change from the default payment method to any other payment method (and also on the online forms unless I set the default to "credit card".) – John Richardson Aug 9 '17 at 20:21
  • 2
    Yes. You were right. It was a file path problem. Thanks Jon G (and also Karin G at semper-IT) for the help. The fix is to go to system settings -> clean up caches and update paths. This worked for me. Note that I was using the clear caches in D7 "Performance" menu before. It may have been as simple as using the "clean up caches and update paths" in the civicrm admin. Thanks again for pointing me in the right direction! – John Richardson Aug 9 '17 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.