2

I'm getting an error on submitting events where "pay later" is selected as payment method. The page times out - if I select a different payment method the next page loads OK.

This is the error I'm getting

Notice: Undefined index: event in CRM_Core_Payment_ProcessorForm::preProcess() (line 78 of xxxxxxxx/sites/all/modules/civicrm/CRM/Core/Payment/ProcessorForm.php).

Has anybody else experienced this?

  • I have the same behavior when I try to change "Payment Method". I've a message saying that there is a network problem, form buttons become grayed, and I have the same error message in db logs. I'm running CiviCRM 4.7.24 (updated some days ago). I've not noticed this error before this update. – olivier Sep 18 '17 at 21:41
1

Welcome to civicrm stackexhange!

Your first step is to try replicate this on - http://dmaster.demo.civicrm.org

Configure things just like you have in your own civicrm.

And if you find you get the same error then amend your question with details/screenshots so that we can reproduce next.

  • I've just done a quick test on the civi sandbox, but I note that this is running version 4.7.25 - compared to the current recommended version of 4.7.23 which we are running on the site with the issue. This is not comparing like with like - the issue may be related to a bug fixed in 4.7.25. – Jon Pollard Aug 11 '17 at 14:32
  • Which is why we test on our current dmaster 😀 – KarinG - Semper IT Aug 11 '17 at 17:12
  • Hi Karin, are you saying that if I test this using the 4.7.25 sandbox version and I don't get the error that this then indicates that the problem is fixed in 4.7.25? If that is the case then should I update my production site to 4.7.25? – Jon Pollard Aug 14 '17 at 10:57
  • Oh no - never update production site to the latest - if you dont't get the error on dmaster demo then we know a) something has been fixed or b) it's specific to your instance - that's how we triage bugs - trying to figure out the where and when. – KarinG - Semper IT Aug 14 '17 at 14:31
  • So, my point is that because it's a different version, you don't know whether it's a or b - so not very much better off. I've done another test on a sandbox I set up myself using 4.7.23 and that doesn't give me the error - meaning it must be something to do with that specific installation. – Jon Pollard Aug 14 '17 at 17:05
0

I can't reproduce this on the civi sandbox. But I don't now why 'event' is not defined. I have these logs in drupal : Référent http://xxxx/index.php?q=civicrm/contact/view/participant&reset=1&id=2825&cid=6632&action=update&context=participant&selectedChild=event Message Notice : Undefined index: event dans preProcess() (ligne 78 de /xxx/xxx/xxx/sites/all/modules/civicrm/CRM/Core/Payment/ProcessorForm.php). As workaround I've just updated line 78 : if (empty($currency) && !empty($form->_values['event'])) {

  • updating Jquery (using jQuery Update drupal module) resolve this problem. – olivier Dec 11 '17 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.