5

We are running CiviCRM 4.7.23 + Drupal 7.56.

If we try and access one of our Drupal User Records via the CiviCRM Contact record (View Contact -> Actions -> User Record) we get a 404 "Page not found" error from Drupal.

In trying to debug this, we've noticed that the URL generated by the "User Record" link in CiviCRM is like this:

http://oursite.org/user/XXXX&cid=YYY

Where XXXX is the Drupal User ID and YYY is the CiviCRM Contact ID. If I strip off the &cid=YYY part from the URL, the link works and takes me to the correct User Record.

So, is this a bug, or is our site misconfigured somehow?

3

I just tested on a site. Clicking the link as described above i get sent to

user/2&cid=39941

and that page shows.

BUT

if instead I just click on the Contact ID / User ID | 39941 / 2 that sits just under Tags on the Contact Summary screen

enter image description here

I get sent to

user/2 and that sounds like it might work in your set up

Does your Summary Screen not show that? (ie I wonder why you are not using that rather than going via Actions which is an extra click)

I can't explain why the link with &cid=YYY is failing for you

  • 1
    Thanks for your answer, it does indeed present a useful workaround that we will likely use. It also suggests that my problem is a misconfiguration rather than a bug. I've given you a useful tick, but don't have enough reputation for that to stick. I'll upgrade to accept if I don't get a better offer! – Rob Hills Aug 13 '17 at 5:52
  • I gave your question and comment a +1 to help get you more reputable ;-) – petednz - fuzion Aug 13 '17 at 6:06
  • and agree. save your 'accept' in case someone comes along and gives you an explanation about how your config might be messed up, as I can't immediately point to anything – petednz - fuzion Aug 13 '17 at 6:07
  • 1
    I have run into the same issue. I think Rob Hills, you can rest assured that your configuration is correct. Every D7 site I have checked where /user/XXXX&cid=YYY results in a 404 page. If it were /user/XXXX?cid=YYY, it would be fine. I suppose we will just have to wait for the 4.7.26 release. – Andrew Wasson Oct 12 '17 at 0:19
1

I can confirm that on all sites I have access to that this is an issue. I poked around the code and can not figure out why the cid is being appended to the url I'm going to submit this as a bug

0

I just found this error in two client sites and testing in CiviHosting demo by selecting user record for demo contact has the same error. it looks like the url is missing a / before the &. When the missing / is added to the url it goes to the correct page.

enter image description here

  • 1
    Other facts - our client sites are running civi 4.7.22 (after upgrading from 4.7.14). Civi Hosting is running 4.7.20 so it seems to have been introduced between 4.7.14 and 4.7.20. – Dave T Aug 19 '17 at 3:02
  • 1
    This AM, the same sites including CiviHosting demo work OK. The url now is just civicrm.demo.civihosting.com/user/2 which does not include the CID info. Any ideas on why the URL would change? caching issues? – Dave T Aug 19 '17 at 13:18
  • Thanks Dave, my html is now a bit rusty, but I wouldn't have expected a "/" before an "&" as the latter is usually a parameter to the path, which doesn't usually terminate with a "/", see en.wikipedia.org/wiki/URL – Rob Hills Aug 20 '17 at 6:38
  • To test Dave's hypothesis about caching being a possible cause, I tried the following: 1. Drupal: flush all caches; 2. CiviCRM: Administer -> System Settings -> Cleanup Caches; 3. CiviCRM: Administer -> System Settings -> Reset Paths. None of these has fixed my problem, the same broken link results. – Rob Hills Aug 20 '17 at 7:06
  • Hmm, I obviously don't understand how markdown works on this site, can't get a numbered list to display properly, sorry! – Rob Hills Aug 20 '17 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.