0

I am unable to access the Civi administrator section on a website using Joomla 3.7.5, Civi 4.7.23 and running on PhP 7.0. Joomla portion works fine, but when I access Components/Civicrm from the Joomla backend, I get a blank page with no error messages (although Joomla debugging is turned on). Using Firefox Developer edition's debugger the response is "Page has no sources".

I then created a new Joomla user with superuser privileges. Logged in and got the following message (screenshot attached). errormessage

Since I can't login to change settings to display all errors and turn on backtrace, how do I troubleshoot? Any help would be appreciated.

Thanks, Kate

Fatal error: Uncaught CRM_Core_Exception: [0: Transaction integrity error: Expected to find active frame thrown in /home/sherida1/public_html/jgs-live/administrator/components/com_civicrm/civicrm/Civi/Core/Transaction/Manager.php on line 107
2
  • Have you recently migrated your website?
    – Giovanni
    Aug 21, 2017 at 13:57
  • Hi GrannyKat - you took the time to ask a question, and others make the effort to provide useful answers. It would be good if you could acknowledge them, and ideally Accept (and +1) or let them know via comments why it didn't apply to your situation
    – petednz - fuzion
    Nov 20, 2018 at 1:07

1 Answer 1

1

You have two options for troubleshooting:

  • Debug and backtrace info should also be in your CiviCRM logs, stored in the ConfigAndLog directory.
  • You can enable debug and backtrace by adding these three lines to civicrm.settings.php:

    global $civicrm_settings; $civicrm_setting['Developer Preferences']['debug_enabled'] = TRUE; $civicrm_setting['Developer Preferences']['backtrace'] = TRUE;

2
  • You can also set these under menu Administer>System Settings>"Debugging and Error Handling"
    – BruceW
    Sep 20, 2018 at 20:20
  • @BruceW ordinarily true, but in this case they're saying they weren't able to reach the Civi admin screens. Sep 20, 2018 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.