1

I'm aware that this has been asked (and sort of answered) Front end event registration works fine but after confirmation screen the error message below appears But this time I can fix it by disabling a plugin called geodirectory

Ideas anyone? Running 4.7.10 on Wordpress and yes basepage is set.

backTrace:

#0 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(367): CRM_Core_Error::backtrace()
#1 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Request.php(120): CRM_Core_Error::fatal("Could not find valid value for id")
#2 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Event/StateMachine/Registration.php(52): CRM_Utils_Request::retrieve("id", "Positive", Object(CRM_Event_Controller_Registration), TRUE)
#3 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Event/Controller/Registration.php(47): CRM_Event_StateMachine_Registration->__construct(Object(CRM_Event_Controller_Registration), TRUE)
#4 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(307): CRM_Event_Controller_Registration->__construct("Event Registration", TRUE, "null", NULL, "false")
#5 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#6 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#7 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm.php(1227): CRM_Core_Invoke::invoke((Array:3))
#8 /home/leepngo/public_html/wp-content/plugins/civicrm/includes/civicrm.basepage.php(132): CiviCRM_For_WordPress->invoke()
#9 [internal function](): CiviCRM_For_WordPress_Basepage->basepage_handler(Object(WP))
#10 /home/leepngo/public_html/wp-includes/class-wp-hook.php(298): call_user_func_array((Array:2), (Array:1))backTrace

#0 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Error.php(367): CRM_Core_Error::backtrace()
#1 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Utils/Request.php(120): CRM_Core_Error::fatal("Could not find valid value for id")
#2 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Event/StateMachine/Registration.php(52): CRM_Utils_Request::retrieve("id", "Positive", Object(CRM_Event_Controller_Registration), TRUE)
#3 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Event/Controller/Registration.php(47): CRM_Event_StateMachine_Registration->__construct(Object(CRM_Event_Controller_Registration), TRUE)
#4 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(307): CRM_Event_Controller_Registration->__construct("Event Registration", TRUE, "null", NULL, "false")
#5 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:15))
#6 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#7 /home/leepngo/public_html/wp-content/plugins/civicrm/civicrm.php(1227): CRM_Core_Invoke::invoke((Array:3))
#8 /home/leepngo/public_html/wp-content/plugins/civicrm/includes/civicrm.basepage.php(132): CiviCRM_For_WordPress->invoke()
#9 [internal function](): CiviCRM_For_WordPress_Basepage->basepage_handler(Object(WP))
#10 /home/leepngo/public_html/wp-includes/class-wp-hook.php(298): call_user_func_array((Array:2), (Array:1))
#11 /home/leepngo/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters("", (Array:1))
#12 /home/leepngo/public_html/wp-includes/plugin.php(515): WP_Hook->do_action((Array:1))
#13 /home/leepngo/public_html/wp-includes/class-wp.php(746): do_action_ref_array("wp", (Array:1))
#14 /home/leepngo/public_html/wp-includes/functions.php(955): WP->main("")
#15 /home/leepngo/public_html/wp-blog-header.php(16): wp()
#16 /home/leepngo/public_html/index.php(17): require("/home/leepngo/public_html/wp-blog-header.php")
#17 {main}
Sorry but we are not able to provide this at the moment.
Could not find valid value for id
Return to home page.
  • I some way the WordPress Geodirectory plugin seems to mess with the Event Page URL. It is looses its id paramater value. You can try to trace the used urls to see were the difference is. The tool HttpFox (addons.mozilla.org/nl/firefox/addon/httpfox) is usefull for this. – Kainuk - CiviCooP Aug 23 '17 at 8:31
  • Thanks - the addon is in Dutch? other posts have referred to the ID getting lost but I'm no nearer a solution – LesleyJill Sep 5 '17 at 5:47
  • It is not Dutch (I am). By accident I copied the language setting in the URL. You can find the English page at addons.mozilla.org/en-GB/firefox/addon/httpfox . Another option in Chrome is open the Developer tools and go to the network tab. – Kainuk - CiviCooP Sep 5 '17 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.