1

I've install clean WordPress 4.8.1 by softaculous and CiviCRM 4.7.23. But when I access to System Status (wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/status) & New Mailing (wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fa%2F#/mailing), it shows only blank page.

I've tried install WordPress 4.8.1 and CiviCRM Long Term Support version 4.6.31, It works normally.

It's very strange that when I turn on Debug Mode, 2 link above can access normally like picture above. Please show me how to fix this.

Access to CiviCRM status

2

Check whether image Image Directory and Image Upload URL share the same path in System Setting -> Directoty & Resource URL page.

This issue of 404 has been seen on some installs. See - Status page angular load error

  • My Image Directory and Image Upload URL share the same path in System Setting -> Directoty & Resource URL page has same path. I'm following other answers in your link (Noah Miller) by going to "Administer => System Settings => Debugging" and disabling the "Asset Cache" and 2 site show normally but I think this is temporary solutions. – ToanLuong Aug 24 '17 at 17:03
1

I have not seen this on a clean install, but have on an upgrade. Can you go to Administer --> System Settings --> Cleanup Caches and Update Path

First click Cleanup Caches once that completes, click on Update Paths.

Then try to access both System Status and New Mailing.

If they still do not appear we'd need to see what errors are being shown in the browser console.

  • I've tried Cleanup Caches and Update Path but it's not working. This is my browser console after access System Status and New Mailing (same error) imgur.com/hj5Ekvg Failed to load resource: the server responded with a status of 404 () angular-modules.b8ea776e799b0ca77fe7c811a12a5e2b.js – ToanLuong Aug 24 '17 at 11:32
  • I have seen this where CiviCRM is stioring the paths to the files. Can you let us knowthe path to where CiviCRM is installed? remove any username for example '/home/user/htdocs/wp-content/plugins/civicrm' – Kevin Cristiano Aug 25 '17 at 11:46
  • My Path CiviCRM install is: [cms.root] home4/myusername/public_html/truyenthongtrangden.huuich.vn [civicrm.root] /home/myusername/public_html/truyenthongtrangden.huuich.vn/wp-content/plugins/civicrm/civicrm [civicrm.files] /home/myusername/public_html/truyenthongtrangden.huuich.vn/wp-content/uploads/civicrm By going to "Administer => System Settings => Debugging" and disabling the "Asset Cache" and 2 link show normally but I think this is temporary solution. – ToanLuong Aug 25 '17 at 21:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.