I use webforms quite a lot including for data entry. Normally when I enter data I enter it when I am logged out so that the data gets added to the correct record and not to the record of the logged in user.

However I would like to enter data and use the private field option of webform - to do this I need to be logged in.

I see on the webform set up there is an option:

Prompt for users who are logged in as, or following a hashed link for, someone else.

Display message to known contacts? [yes]

I have enabled this however when I am logged in I do not see this message. When I view page source it is there "h2 class="element-invisible">Status message ul>

  • You are viewing this form as XXXXXXX. Please click here if that's not you.
  • You have already submitted this form. View your previous submissions.
  • "

    So I am wondering why the message has been rendered invisible?

    I have had a look at form settings and so on but I cannot find a tick box which explains how I have managed to make it invisible!

    Any tips as to where to look would be gratefully received! Thank you


    In the CiviCRM section of your webform, the third section down is "Not You?" Message. There's a check box there for "Display message to known contacts?"


    Another approach to something like this is to have a Drupal Views search block in a sidebar, search for your contacts there, and set their name up as a link to the Webform with their id attached to the url as ?cid=xxx

    • That's really interesting I didn't know you could do that! That will help me on another task! However in this data entry task lots of the surveys are filled in by people who are not on the database. Which is why I want. Someone who is logged in to be able to enter multiple contacts whilst also ticking a private field which says this is a paper survey not an online survey.
      – Caroline B
      Aug 25 '17 at 10:20
    • Do you think this is a theme error?
      – Caroline B
      Aug 25 '17 at 10:20
    • it sounds like a setting on the contact component on the webform. how do you have it set?
      – petednz - fuzion
      Aug 25 '17 at 21:55

    Your Answer

    By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

    Not the answer you're looking for? Browse other questions tagged or ask your own question.