4

When you close an accounting batch, you are asked if you want the exported file in IIF or CSV. We export to CSV every time since we don't use Quickbooks. Just now, however, our office manager accidentally chose IIF. "No worries," I thought, "we'll just re-download it and choose CSV." No dice.

When you go to Exported Batches and click Download, you are not given the choice of format, it just begins downloading another IIF. To fix it, I went to the civicrm_batch table in the database, found the batch in question and changed its status ID to 2 (Closed). This allowed our office manager to export it again, but in the correct format. (There must be an association somewhere in the database between file format and export batches; I wonder where that is... I digress).

My actual question: What is the best way to prevent choosing the wrong export file format on the batch export screen? Disable the IIF option with CSS and/or JS? Can I prevent the IIF option from even systematically appearing since we don't use it? Where would I adjust that?

2

[Old question, but may still be relevant]

A quick but hacky option would be to comment out the IIF line in $optionTypes in CRM_Financial_Form_Export::buildQuickForm()

A better option would be create a setting and use that to set $optionTypes which would be a straightforward enhancement. Since a site probably wants the same type for every batch, a setting under CiviContribute Component Settings seems reasonable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.