3

CivCRM version 4.6 PHP Version 5.6 CURL was installed with apt install php-curl

The CiviCRM home page insists that CURL is not installed but all indications are that is is installed. My phpinfo() shows that is it is. I can execute it from the command line.

I've searched for solutions but can't find it yet

4

CiviCRM has detected that the function curl_init is not available, and is showing a warning.

Commandline phpinfo() will show changes immediately (since PHP is started for each execution), while PHP in the webserver needs you to restart it separately to pick up new PHP modules. (These modes of running PHP also have different configurations loaded per default - but apt should already have enabled curl for each.)

You can verify this by checking phpinfo through the webserver (eg in Drupal, visit admin/reports/status/php; in WordPress you might need to use this phpinfo plugin or just create a phpinfo file in your site. If you see curl missing there, it could be a reload is all you need.

Depending on your webserver configuration (PHP can run as FPM, mod_php, etc), you'll need to restart the service (eg apache2, php-fpm) which runs PHP on your server. Most likely,

sudo service <your php service> reload
4
  • Reloading php-fpm did the trick. On my system I'm running two versions of php. I issued the following: sudo service php7.0-fpm reload There was no separate service for 5.6 but this worked. – Vietyank Aug 29 '17 at 4:48
  • Dumb question but how do I found out what to put in <your php service>. cUrl was already installed before I installed CiviCRM but I'm getting this message anyways and want to see if this still helps. – Christia Nov 20 '17 at 22:57
  • 1
    Hi Christia! service is a command to manage running daemons, and (assuming a particular kind of *nix/distro, anyway) you can list the services installed on your system with sudo service --status-all. Likely candidates are php5-fpm, php7.0-fpm etc. In the absence of any php-ish things, probably you want apache2 or httpd ... but look for PHP services first :) – Chris Burgess Nov 21 '17 at 3:41
  • Thanks! service apache2 reload worked for me. Edit: or not. I'll post a separate question. – Christia Nov 27 '17 at 18:45
1

if you're running apache, did you restart it after installing php-curl?

3
  • You put it far more succinctly than I did 😜 – Chris Burgess Aug 26 '17 at 20:08
  • but you showed citations and details. I think you won :) – ericG Aug 26 '17 at 20:22
  • Yes but I did not restart php-fpm which I will do when I get back to this project – Vietyank Aug 29 '17 at 4:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.