2

Up until recently, the cron job I had set up was running correctly and the Scheduled Jobs were being run. However, since I upgraded (currently running 4.7.21) I am now getting an error message that the cron job isn't running. I made no changes to the cron job. BUT when I check the log, it says the job has been run although it doesn't appear that the task was done. I have Joomla 3.7.4.

The Error message is System Status: Warning Performance warning: Missing indices Cron Not Running Remote Profiles Enabled

The log says Entity: Job Action: process_membership Summary Finished execution of Update Membership Statuses with result: Success (Processed 159 membership records. Updated 0 records.)

Details Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;}

Full message: Finished execution of Update Membership Statuses with result: Success (Processed 159 membership records. Updated 0 records.)

The cron is -

curl -s 'https://ashguild.ca/home/administrator/components/com_civicrm/civicrm/bin/cron.php?name=weaverfran&pass=#####&key=#####’
  • Since the Admin console says "Cron not running" I'm guessing that the job log is referring to an older cron run. Can you please edit your question to clarify whether the "Last Run" column on Administer menu » System Settings » Scheduled Jobs is getting updated or not? – Jon G - Megaphone Tech Aug 29 '17 at 17:25
  • The Last Run date was August 28. – Fran Nowakowski Aug 29 '17 at 23:25
  • Could you please look up the lastCron value? Go to Support menu » Developer » API Explorer. Set the Entity to StatusPreference and Action to get. Press Execute. In the values below, find the one with the name of "checkLastCron" and report back the value listed next to "check_info"? – Jon G - Megaphone Tech Aug 30 '17 at 3:59
  • It is - check_info": "1504069203" – Fran Nowakowski Aug 30 '17 at 21:46
0

Based on your comments, I was able to use https://www.epochconverter.com/ and see that cron was last run at 5am (GMT) on August 30th. You submitted that comment around 10:30pm GMT. That strongly suggests your cron is a) working correctly, but b) isn't running at least hourly. This causes the "Cron not running" warning. It's possibly also the cause of the scheduled job not working correctly, though not definitively.

Please update your cron settings to run at least hourly (I recommend every 15 minutes if you use CiviMail). Once that's done, either a) please let us know if it solved your problem, or b) edit your question to reflect the updated situation.

  • Thank you. Changing the cron setting to run hourly DID get rid of the Error message and the Jobs did run but not successfully. For example the updating membership statuses did not happen. This is the cron I have setup - curl -s 'ashguild.ca/home/administrator/components/com_civicrm/civicrm/…' . Am I doing something else wrong? – Fran Nowakowski Aug 31 '17 at 18:34
  • I can't seem to add the cron code to my message. It gets truncated. – Fran Nowakowski Aug 31 '17 at 18:36
  • Could you please edit your question to reflect the cron setup that's truncated in the comments? Also, please see if other scheduled jobs are working properly; it's possible that the issue isn't cron, but your CiviMember configuration. Detecting if other scheduled jobs are working will help us isolate the issue. – Jon G - Megaphone Tech Sep 1 '17 at 1:11
  • The member status updates are not successfully running neither is the scheduled reminders job. I'm sorry I don't know how to format the cron setup so that it is not truncated. I've tried a couple of different options but they all end up truncating. – Fran Nowakowski Sep 1 '17 at 14:16
  • If you edit the question to include the truncated version, I can press "Edit" and fix it. I can't edit your comments though. Please comment on this answer so I see that you've updated it? – Jon G - Megaphone Tech Sep 1 '17 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.