2

The membership form https://www.colongwilderness.org.au/join-donate-membership has the option to select a membership or 'none' and make a donation.

If just a donation is chosen then the form submits and says that the payment was successful but no payment is recorded either with the gateway or with CiviCRM.

This is what the form looks like

The presentation of the form

If you choose

  1. Membership - none -
  2. Additional Donation $5

The submitted form says that the payment has been submitted to eway, but there is no record with eway or record of the contribution.

The Contribution p9age does not have 'membership required'.

contribution form

The price set doesn't have anything as required. If the value to be submitted is $0 then the credit card form is not displayed correctly.

This is what the price set looks like

Price set

CiviCRM 4.7.22.

0

Do the following :

  • menu Contribution -> Manage Contributions Pages
  • configure -> Memberships Settings
  • at the bottom, there should be a checkbox "Separate Membership Payment".

Confirm that it is checked or not. In doubt, don't check this box because i think not all gateway support it. You can at least give it a try.

  • I have this setting only on sites which have 'no membership price sets' and/or 4.5.2 CiviCRM. On 4.7.22 with a price set it isn't there. – Interlated Sep 5 '17 at 5:53
  • Hmm, you're right. In that case, i don't think the payment is separated so it shouldn't be the problem you have. Can you try to make both field required with a $0 option ? – samuelsov Sep 5 '17 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.