1

As you can see in the picture below, icons do not show. They are missing on all pages, also on buttons. This does not change after emptying cache and rebuilding the menu. I've also checked the resource URL, and it seems to be correct. Do you have any idea, what might be the problem?

Thanks a lot in advance and best regards!!

icons do not show

  • What CMS are you using? And have you click on the "Refresh Dashboard Data" and clear your cache? – Kristine Sep 2 '17 at 22:26
  • Dear @Kristine , thanks for your answer. I'm using CiviCRM on WordPress and I've cleared the cache already without changing the issue. Also refreshing the dashboard data didn't solve the issue. It's not a dashboard issue, rather the problem appears through the whole installation. – Jannis Eicker Sep 3 '17 at 10:00
  • Check the paths: Administer -> System setting -> Resource URL and Admin -> S/m setting -> Directories and see if all of them are configured correctly – jitendra - fuzion Sep 3 '17 at 10:04
  • Dear @jitendrapurohit, thanks for your answer. The interesting thing is that I had to change the default URL after upgrading because otherwise the CiviCRM dashboard wouldn't load. But now it does load, so I guess the ressource URL should be alright. It reads netzwerk-n.org/crm/wp-content/plugins/civicrm/civicrm – Jannis Eicker Sep 3 '17 at 10:36
  • Dear @jitendrapurohit, maybe you're right regarding the directories. The only problem is, CiviCRM doesn't allow me to change the directories' paths. When I try to change the tempory files directory's path from relative to absolute in the way I did it with the resource URL, it tells me that the directory doesn't exist... I'll try to go into the settings.php to see whether there's a mistake – Jannis Eicker Sep 3 '17 at 10:48
2

Following my comment - You need to provide existing path in the resource url and directories page. Click the help icon to see the values of diferent global variables that you can make use of(civicrm.files, etc).

You can override these values in civicrm.setting.php file according to your paths. More info at https://civicrm.stackexchange.com/a/19498/245

  • Thanks again for your answer. However, the directories' paths must have been correct before already. Because when I changed the paths in the setting.php to random paths, CiviCRM gave me error pop-up windows right away on the dashboard. After changing the directories' paths again, the pop-up windows stating the errors didn't show up again. Furthermore, using the overriding function in the settings.php with the right paths – which I checked via FTP – also didn't solve the problem. Or did I get your comment wrong? By the way, the facebook photo doesn't seem to be related to the issue at all. – Jannis Eicker Sep 3 '17 at 18:49
  • 1
    Sorry, I pasted the wrong link before. Updated. – jitendra - fuzion Sep 4 '17 at 13:49
  • Thanks for the link. That looks interesting, I'll try it as soon as possible! – Jannis Eicker Sep 4 '17 at 15:04
  • Thanks again, it actually solved the problem. Although I had to change the solution a bit. Instead of adding a global files URL and path to the setting.php, I only added the URL, because after also adding the path, the icons existed, but the extensions were gone. So instead of global $civicrm_paths; $civicrm_paths['civicrm.files'] = array( 'url' => 'https://example.com/foo', 'path' => '/var/www/example.com/foo', ); I only added global $civicrm_paths; $civicrm_paths['civicrm.files'] = array( 'url' => 'https://example.com/foo' ) – Jannis Eicker Sep 4 '17 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.