1

After setting up and configuring Civicrm 4.7.20 w/latest Wordpress (4.8.1 or so) I upgraded to 4.7.21 all seemed to go well. Then I logged in and tried 'test drive' an Event, and 'live' registration. In 'live' mode, the default service fee I set up was doubled. I created a test system locally and turned on debugging, tried Smarty debug and the relevant price set fields all looked correct. In NetBeans I checked the Register form after the setDefaults call, values were correct, but any price I set up with a 'default' was doubled by Calculate.tpl
I know this is very specific and I didn't expect to find a solution on stack exchange.

2

It turned out that the problem was due to a Wordpress plugin I set up called Inactive Logout (https://wordpress.org/plugins/inactive-logout/) caused the problem. Once I deactivated the plugin all worked well. Moral of the story: beware the smiling WP plugin, the javascript that bites, the session vars that snatch, beware the easy download and shun the frumious extension. On a serious note I think the plugin doubled the logged-in users but have to investigate.

It turned out the problem was caused by a call to wp_footer in src/inactive-logout-functions.php line 16, commenting-out that line fixed the problem and the inactive logout still works. wp-footer appends data to the /body tag

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.