2

For several months we have been seeing the error "Cron Not Running". I have repeatedly configured crontab for the root user, and currently have the following:

0 * * * * wget -O - -q -t 1 https://<redacted>/cron.php?cron_key=<redacted>
0 * * * * drush -r /var/www/html/drupal -l https://<redacted> civicrm-api -u <redacted> job.execute

I have followed the Managing Scheduled Jobs documentation each time, but still cannot figure out what I am doing wrong.

What might I check to make sure Cron is configured correctly?

  • This issue has affected us for many months. I have tried several solutions, and it won't go away. – Brylie Christopher Oxley Jan 22 at 11:12
2

I may have solved this with the following steps.

  1. create a drush alias for the site
  2. configure crontab using the drush alias

Drush alias (~/.drush/example.aliases.drushrc.php)

<?php

    $aliases['example.com'] = array (
        'uri' => 'example.com',
        'root' => '/path/to/drupal',
    );

?>

Crontab

0 * * * * drush -u 1 @example.com civicrm-api job.execute auth=0 --out=json
0

This works for me in Cpanel, including the wget:

wget -O - -q -t 1 'http://mysite.org/drupal/sites/all/modules/civicrm/bin/cron.php?name=myusername&pass=mypassword&key=123456789abcdefg'

Note the single quotation marks at start and end of syntax - after wget string

  • On mine it was necessary to add the path to wget. Cron had no default paths associated with it. – Codedogs Sep 27 '17 at 17:56
  • My cron is running in Cpanel without -O - -q -t 1 - what is "O - -q -t 1"? – themak Oct 30 '17 at 17:10
  • Please refer to the wget manual on gnu.org/software/wget/manual/wget.html#Option-Syntax – Hock Oct 30 '17 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.