We consult with CiviCRM powered by Drupal. Recently we upgraded one client who has CiviCRM powered by the latest Drupal 6 from 4.5.8 to 4.6.2. After the upgrade, they are unable to click between the various tabs of a CiviContact record. They have tried multiple different browser products from I believe their Windows based computer.

Tabs are as follows on a particular CiviContact record: Summary Contributions 263 Pledges 0 Memberships 0 Activities 61 Events 7 Relationships 0 Groups 41 Notes 2 Tags 5 Change Log 18

Always the lower content area is stuck showing the Summary details. We see no troubles from Mozilla Firefox on Linux, or Google Chrome. I tried Chrome as they say that is their preferred browser.

Some time ago I recall some AJAX code getting broken in a couple of CiviCRM upgrade on Drupal 6. Perhaps that has happened again. Though odd this time it is specific to the operating system of the browser, not a cross-platform break.

Any other suggestions of information I might provide?

I am thankful, Michael


4 Answers 4


Aaahhhh!!!! I just noticed that this client's Drupal user ID was set to view the site with the default Garland theme whereas my Drupal user ID was set to view the site with the custom theme built for this site. I switched the client's Drupal user ID to use the custom theme, and now AJAX refreshes correctly. So, it appears Drupal Garland theme specific.


I suggest you start by going through the steps for troubleshooting javascript in CiviCRM. If that doesn't fix the problem, please edit the question to report back what data you've gathered from the process.


It could be cached resources in their browser. Ask them to do a force-refresh (ctrl-shift-R in Chrome & FF).


It appears to be specific to this client's computers verses our development computers. I have had success with Mozilla Firefox both in my native Linux, and also a Windows VM.

However the client has attempted to connect from their Windows 7 computer with Google Chrome, Internet Explorer 11, and Mozilla Firefox. The problem is consistent across all these browsers. It appears to be a consistent AJAX issue for this client.

The client installed Mozilla Firefox to debug this issue. Their preferred browser is Google Chrome... so definitely old cached files is not the answer.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.