1

I've just upgraded a site that was running Civi 4.6.30 to 4.7.24. I use OpenStreetMaps as the Mapping provider. My maps are now appearing as featureless grey maps rather than what I'd expect.

The same seems to be true when I test it on http://dmaster.demo.civicrm.org

My old site continues to render the map in full colour.

The template concerned (CRM/Contact/Form/Task/Map/OpenStreetMaps.tpl) certainly looks very different between the two versions of Civi that I've upgraded from/to.

2

As Graham has noted in a comment, the change in map reflects a change in terms of use and distribution methods in July 2016 that necessitated the removal of direct links to MapQuest tiles.

The plain map you are seeing is the Carto Light basemap from Carto, which was adopted as of 4.7.19.

On our sites, we do not use the built-in maps for the public, but a Leaflet implementation for Drupal Views. Thus, this change only affected internal users who use the mapping, which does not occur often in our use cases. But for those who do, you can override this choice by adding a custom OpenStreetMaps.tpl template, with the URLs appropriate to your tile provider of choice.

Carto Light All Carto Dark Nolabels

I am not sure if any Carto tiles other than the basic light and dark (with or without labels) are licensed for this kind of use, however. The OSM wiki does provide a list of tile servers where you can explore alternatives.

  • Thanks for this information. Maybe I missed the men on this. Essentially what you're saying is that the CiviCRM mapping implementation using OSM data is now at best severely hobbled. – Graham Sep 12 '17 at 16:41
  • LOL, I didn't see that you'd commented on your own question. But yes, I suppose if you prefer the old MapQuest tiles, this is a downgrade. See wiki.openstreetmap.org/wiki/Tiles for some other alternatives. – choster Sep 12 '17 at 16:48
  • What I don't understand - yet - is why a Civi/Drupal site that I have running an older version of Civi is still able to render OSM maps perfectly well. According to the information I've read I should be seeing an alert message instead to tell me that it's all been switched off? – Graham Sep 12 '17 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.