3

I am using Civi 4.7.22 on Wordpress 4.8.1 I am having problems with the link tracking. In both the email template preview and the actual sent email, links are going to a 404 Error page when tracking is enabled. When tracking is disabled, the links work properly.
Also when editing the email template, when I click the "Browse Server" option I am redirected to a 404 Error Page.
This makes me think something in the url for tracking and the civimail feature itself is not configured properly. Can anyone tell me where to look to fix this? Please let me know what additional information you need.

Thank you.

  • Can you please give an example URL that fails? You can redact your domain name, but it can point to any problems. – Jon G - Megaphone Tech Sep 14 '17 at 20:23
  • All of the urls are failing except the ones that are Tokens. The Browse Server button is going here site.org/wp-content/plugins/civicrm/civicrm/packages/kcfinder/… instead of letting me browse for the item. The links are going here site.org/wp-content/plugins/civicrm/civicrm/extern/… but is opening a 404 Error pages instead of redirecting to the correct page. – fdarn Sep 14 '17 at 22:29
  • Could you give more details? For e.g whats your: 1. directory settings (Administer >> System Settings >> Directories) 2. resource url settings (Administer >> System Settings >> Resource URLs) 3. wordpress base path settings (Administer >> System Settings >> CMS Database Integrations) – Deepak Srivastava Oct 9 '17 at 16:58
1

I'm not sure this is quite the same problem as I had, but it may be worth looking at. I'm in WordPress 4.9, CiviCRM 4.7.22. I was getting Error 500 for all the tracked links and I resolved this by changing [civicrm.root]/extern/url.php to 644 permission and the containing directory to 755. I've had a lot of similar problems (e.g. with getting images into KCEditor with KCFinder. One of the incomplete screens I get there (problem not entirely solved) is the same as I get with the Browse server button that you mention).

I think its all to do with the fact that I have a hosted solution (SiteGround) and it insists on 755 and 644 permissions whereas a lot of WordPress files are 775 and 664, which I think is only appropriate for stand alone hosting (again need more research).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.