1

I have a WordPress 4.2.1 site with CiviCRM 4.6.2, this is a fresh install. I have one event with registration and the default registration page:

?page=CiviCRM&q=civicrm/event/register&reset=1&id=1

shows no registration fields. If I visit

aaaaa/?page=CiviCRM&q=civicrm/event/register&reset=1&id=1

then I see the registration fields or if I visit

event/?page=CiviCRM&q=civicrm/event/register&reset=1&id=1

or

bbbbb/?page=CiviCRM&q=civicrm/event/register&reset=1&id=1

where aaaaa and bbbbb are indeed valid slugs on my site. If I visit

ccccc/?page=CiviCRM&q=civicrm/event/register&reset=1&id=1

where ccccc is not a slug, then I get a 404 Error page.

I have no "WordPress Base Page" set at

civicrm/admin/setting/uf&reset=1

and the wp_users is set correctly as Users Table Name. I have " Your latest posts" set for the "Front page displays" in WordPress so that seems OK.

Something also odd is that the above URL is actually

civicrm%2Fadmin%2Fsetting%2Fuf&reset=1

in my browser. Not sure why...

Also when I visit

admin.php?page=CiviCRM&q=civicrm%2Fevent%2Fmanage&reset=1

it's fine but if I visit

admin.php?page=CiviCRM&q=civicrm%2Fevent%2Fmanage%2Fsettings&reset=1&action=update&id=1

then I get the dreaded

We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Then try again. If this error persists, contact the site adminstrator for assistance.

Site Administrators: This error may indicate ....

Error type: Could not find a valid session key.

error.

All pages I am testing have www before the myurl.org so that's not the problem.

Any ideas what is going on here?

3

It sounds like you may be having a problem with SSL pages. I suggest checking that you're not switching between HTTP and HTTPS. If you are, try going to Administer menu > System Settings > Resource URLs and changing "Force Secure URLs" to "No" until you have your SSL certificate straightened out.

0

The only way I've been able to resolve is to put all traffic to HTTPS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.