1
I'm using civicrm 4.7.17 on drupal 7.54.  Logged in with administrator rights.

When I try to add a new field, (admin -> customize data and screen -> custom fields) everything works fine.  I create a new set, no problem, but then when I add a new field to the set, and click on save, it just hangs, loading forever. 

This seems to be a new thing as I've created lots of custom fields before. 

Any ideas?

4
  • When you go to add a custom field, please right-click the Add Custom Field button and select "Open in New Tab". When you save the custom field, you should get a more informative error. Better still, first enable debugging. Go to Administer menu > System Settings > Debugging and Error Handling, select "Yes" to both "Enable Debugging" and "Display Backtrace", and press "Save". Repeat the steps that caused your error, and you'll see much a more detailed error. Please update this question with the expanded error and backtrace - and don't forget to disable debug/backtrace when you're done! Sep 19 '17 at 18:34
  • That would make sense to debug it first. So when I made a new tab, and tried to save, it had this error, " Sorry but we are not able to provide this at the moment. id is not a valid integer" Sep 19 '17 at 19:09
  • Added the debugging to the original post Sep 19 '17 at 19:30
  • Glad you worked it out! For reference - the error you gave is the "debug" info but not the "backtrace". The debug shows the error - but the backtrace shows where in the code that error takes place. Both are often necessary to solve a problem. Sep 20 '17 at 16:11
1

OK, so the civirules 1.2 extension was causing the problem. The problem is documented a bit here: https://github.com/CiviCooP/org.civicoop.civirules/issues/132

Luckily I hadn't set up at civirules stuff so it was easy to just disable it. Maybe in the future I'll use an updated version of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.