1

I'm very nearly there with setting up PayPal Standard. I'm using WordPress 4.8.2 and CiviCRM 4.7.22 at present.

I have set up a PayPal sandbox account and everything seems to be working nicely with the exception that it is showing up as (test) in CiviCRM - it took me a while to work this out and find it in the contribution search. I am definitely using the live link (if I use the test link, it goes to a different PayPal sandbox account that I have set up for that and that works as expected to produce a test contribution record.

I have tried it with a membership contribution and an event contribution. If I switch to the dummy payment processor (no other changes) it gets treated as a live contribution, so I think it must be something to do with PayPal but can't see how.

Is there some other setting I might have missed? Any suggestions very welcome.

  • I'm not sure to understand : you want to use paypal sandbox to get real contribution in CiviCRM ? Why would you want that ? – samuelsov Sep 21 '17 at 17:59
  • With the production server, in the payment processor, I will configure the live payments to the real PayPal server and the test server to the PayPal sandbox. I would use the test server for such things as demonstrating a new contribution set up. But currently I'm on a development server, I want to try as much out as possible without any real money (I will do the final testing on the with the real PayPal account). So I set the live server in the PayPal processor to the sandbox and surely it should not think they are test contributions (how would it know?) – Mick Kahn Sep 21 '17 at 21:50
  • I've tried this setup, too. The link for the test contribution page isn't available if you're not logged in, so if you're trying to simulate the user experience without an actual credit card transaction taking place, your only choice is to use the sandbox credentials for live payments. It can be confusing when you can't find the contribution records unless you specify test transactions on your search. – Dan O'Brien Sep 22 '17 at 13:32
1

I have noticed this behavior in the past. When using a PayPal sandbox account, CiviCRM transactions are flagged as "test" even when using the sandbox credentials in the "live" processor configuration.

  • Not the answer I was hoping for! I was hoping that it worked for others and I was doing something stupid. This suggests that it spots the "sandbox" you enter for PayPal and decides its a test, which I think is unlikely and a quick search through Github doesn't find any relevant mentions of "sandbox". I think I will try something to the real PayPal account next. – Mick Kahn Sep 22 '17 at 15:13
  • I'm guessing that it's something in the reply from PayPal that indicates it's a sandbox transaction and CiviCRM is picking it up. I would imagine it's possible to find it in the code and prevent this from happening. – Dan O'Brien Sep 22 '17 at 15:38
  • That is possible, because when I first started looking at this, it seemed to be inconsistent. But some of the tests got stuck pending because I hadn't got everything configured correctly. So this could explain the inconsistency. I will do some more testing, but the good news is that my live test worked fine. – Mick Kahn Sep 22 '17 at 17:09
  • Well, done some testing. First I took the plunge and tried it all with the live PayPal site (setting all the contributions to £0.01) and that seemed to work fine and it doesn't look if PayPal has charged more than £0.01 per transaction. But I can now get no sense out of the sandbox servers used as the CiviCRM live server and they are not completing the transaction on Civi. Can't see what is wrong. I'm giving up for now as I can progress to going live and will have to return to this later. So can't prove or disprove your theory. But at least you have moved me forwards. – Mick Kahn Sep 22 '17 at 22:16
  • Is this a one time transaction or a recurring one? Have you set the IPN URL? – Dan O'Brien Sep 22 '17 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.