1

CiviCRM 4.7.24

We do not use Price Sets, but instead have a selection of Membership types.

Randomly some time today, our membership types got messed up where the our front-end webform is showing membership types that we deleted a long time ago.

When I go into and try editing the Membership Types on the back-end of the webform, those mystery membership types don't even show up.

When I try pick different membership types and Save, the front end does not change at all.

Here is the front end that is showing all of the membership types:

https://lnt.org/civicrm/contribute/transact?reset=1&id=58

It's supposed to only have: $25, $50, $100, $250, $500, and $1,000.

Anyone have any suggestions! I'm not the most technologically savy person out there...

Thanks!

  • Pete - if you want to skype I can take a quick look via your screenshare. otherwise i would ask if you have access to your db so we can see the status of those rows. skype = peter.davis59 – petednz - fuzion Sep 21 '17 at 23:54
  • alternatively paste a shot of your membership tab set up for that contribution page – petednz - fuzion Sep 21 '17 at 23:58
  • Thanks, Pete! Here is what the back-end looks like: lnt.org/sites/default/files/civicrm/persist/contribute/images/… – Peter Dodge Sep 22 '17 at 13:37
  • I was able to figure it out. In the back-end, I "un-abled" the Membership Section of the Contribution Page (ultimately, shutting down our form for a second), quickly saved, and then quickly Enabled the membership section again and selected the membership levels. Basically, "resetting" the membership section. Some of our donation pages (no membership section enabled) were also messed up -- if we had 4 selections originally, a bunch more were added to the list. Manually deleting/reordering those solved that issue. I'm still not sure why this happened, but this worked for us. – Peter Dodge Sep 22 '17 at 13:57
  • Glad you sorted it. Pls add your comment as an Answer and then 'accept' it - gives you 'points' and stops the system complaining about Q with no Answers ;-) – petednz - fuzion Sep 23 '17 at 0:17
1

I was able to figure it out. In the back-end, I "un-abled" the Membership Section of the Contribution Page (ultimately, shutting down our form for a second), quickly saved, and then quickly Enabled the membership section again and selected the membership levels. Basically, "resetting" the membership section. Some of our donation pages (no membership section enabled) were also messed up -- if we had 4 selections originally, a bunch more were added to the list. Manually deleting/reordering those solved that issue. I'm still not sure why this happened, but this worked for us.

0

Although you specifically are avoiding Price Sets, sometime ago we also had trouble getting the correct order to display on our membership signup/renew page, no matter how we ordered our Membership Types. Price Sets solved the problem and we now use Price Sets for all Events and other payment options that are displayed to our members. I know that's not the answer you're looking for, but Price Sets also offer some other nice features for displaying a list of prices (descriptions, help, etc.).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.