1

Using CiviCRM 4.7.22 on Wordpress 4.8.22 We are having a problem with our contribution form submissions. We have a Custom field. When the member submits the form, the information from the custom field is added to the profile in the dashboard, but it shows up as blank in the email receipts to both the member and to the Admins. We need this data to show in the email receipts also. Please see screenshots below for more details.
image 1

Image 2

image 3

Image 4

Image 5

Image 6

Image 7

Image 8

*******ADDITIONAL INFORMATION BELOW******

I noticed that when I add the custom field to the profile it says it is a "Primary" field, but when I go to edit it after adding it, it is no longer a primary field. Why does it change? Could that be what is preventing it from being included in the emails?

This is a "Contact" field, because we need it to appear below the Address area in the member's profile page on civi. It is just a simple membership, not multiple records. I noticed that if I use an "Individual" field instead, it will work properly with the email, but the problem is it puts that field way on the bottom of the member's profile page in civi. This really needs to be close to the address area. So I guess the question is, why does an "Individual" custom field show the data in email receipts, but a "Contact" custom field won't, and how to do we fix that?

enter image description here

enter image description here

enter image description here

enter image description here

*****NEW IMAGE***** enter image description here

  • Great explanation. One of the best bits of documenting a problem I have seen. Sorry I don't have a useful pointer for you. I think the only thing I can't tell from the above is whether the Group of Fields, that this field belongs to, is set for something unusual like 'multiple records'. – petednz - fuzion Sep 23 '17 at 0:43
  • Thank you for your reply. I added some additional information and 4 more screenshots that I hope will shed some light on the problem. – fdarn Sep 23 '17 at 3:09
  • that gives the clue. the fact that it offers 'primary' suggests you/someone set this up as a Location Type field, which seems inappropriate and is probably the problem. i would suggest you discuss how to reset the field so it is not related to 'location types' – petednz - fuzion Sep 23 '17 at 20:30
  • alternatively you could try just setting the Location Type on the profile to eg Home and see if that gets it working for you – petednz - fuzion Sep 23 '17 at 20:31
  • I originally said that from the above I couldn't tell what the Custom Group of Fields was used for. Still not sure you have answered this. Have you added it as a set of Address fields? – petednz - fuzion Sep 23 '17 at 20:35
1

The fact that you are seeing Primary suggests this has been added as an Address custom field, and it seems that these new-ish field types have not been fully integrated to receipting.

You have some options

1/ change your field to a standard Contact field and then edit your tpls to have the field show where you want it (this seems the 'right' way to fix this since otherwise you are using an Address field, with its options of Location Types, for a field that should not be offering Location Types)

2/ get the code improved so these fields do show in the receipts either by contributing a patch or funding a Partner to do this on your behalf and help grow this open source project.

  • Thank you. I did what you advised and stopped trying to use a custom field and just used the "Address Name" field and changed the Label to ID Number. That places it in the perfect spot on in the profile. I appreciate you sticking with me through this and setting us on the right track until we worked it out. – fdarn Sep 25 '17 at 1:50
  • phew glad we got there – petednz - fuzion Sep 25 '17 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.