0

I've switched hosts and the new host's smtp server seems to be rejecting the email I'm trying to send to a group. It can me 2 or 2000 people with the same response. Apparently it does not like the auto generated sender email address? Anyone have that issue and go I d a solution? CiviCRM on WordPress. Both very recent versions.

2017-09-22 16:30:04 [4342] H=(www.sportingdetectiondogs.ca) [184.154.247.100]:33676 I=[184.154.247.116]:25 X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no SNI="sportingdetectiondogs.ca" F= A=dovecot_login:[email protected] rejected RCPT : SITEGROUND: [email protected] is not a valid address: Sender verify failed: Sender verify failed 2017-09-22 16:40:04 [48178] H=(www.sportingdetectiondogs.ca) [184.154.247.100]:42556 I=[184.154.247.116]:25 Warning: SITEGROUND: Message from 184.154.247.100. Normal SMTP auth with [email protected] system user: sporti62 2017-09-22 16:40:04 [48178] H=(www.sportingdetectiondogs.ca) [184.154.247.100]:42556 I=[184.154.247.116]:25 X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no SNI="sportingdetectiondogs.ca" F= A=dovecot_login:[email protected] rejected RCPT : SITEGROUND: [email protected] is not a valid address: Sender verify failed: Sender verify failed 2017-09-22 18:45:24 [26529] H=(www.sportingdetectiondogs.ca) [77.104.151.189]:51718 I=[77.104.151.189]:465 Warning: SITEGROUND: Message from 77.104.151.189. Normal SMTP auth with [email protected] system user: sporti62 2017-09-22 18:45:24 [26529] 1dvXdM-0006tt-Ja <= [email protected] H=(www.sportingdetectiondogs.ca) [77.104.151.189]:51718 I=[77.104.151.189]:465 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no SNI="usm31.siteground.biz" A=dovecot_login:[email protected] S=565 M8S=0 T="Test for SMTP settings" from for [email protected] [email protected] [~]#

2
  • I'm interested in this because I also had a (different) problem with sending mail via my hosting provider (SiteGround) see civicrm.stackexchange.com/questions/20657/…. From the error message or log quoted that you might also be hosting with them. Would be nice to know as we might have issues in common!
    – Mick Kahn
    Commented Oct 25, 2017 at 21:53
  • I posted in your thread. Commented Oct 26, 2017 at 23:08

1 Answer 1

1

two possible sources of the error:

  • you have changed something in the configuration of your mail accounts in civi (or didn't finish the config previously), check the documentation, the "localpart" should not be empty but name of your bounce mailbox (eg if your mailbox is [email protected], it should be "bounce+")

  • civimail relies on a trick that most servers implement: if you send and email to [email protected], it will automatically be understood as an alias of [email protected]

It seems that you need to at least fix the localpart, as your new mail server is more strict and better at catching configuration problems

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.