1

I've just upgraded from 4.4 to 4.7.20. Everything seems to be working as expected, except that the "System Status" page is empty. Just blank where there should be the "CiviCRM System Status" widget. However, I know there are some issues because the footer displays "System Status: Error", and when I log in I see a CivicRM system popup messages listing the issues I need to fix.

When I try to load the System Status page, there are no errors in the CiviCRM logs or in the Joomla/PHP logs. The Firebug console gives a warning "Empty string passed to getElementById()." and references [docroot]/media/jui/js/jquery.min.js

Seems to be similar to this problem

System Status page empty and status remains 'critical' after updating from 4.7.8 to 4.7.11 on Drupal 6

though I am on Joomla not Drupal. And there doesn't seem to be a resolution in that post.

I also found this post (Status Error and blank status page) but I checked and all my permissions seem to be correct.

Ideas?

4

Well, I'm not sure this is a long-term solution, but it is a workaround....

In one of the Angular posts (Status page angular load error) I found this:

another work-around should be going to "Administer => System Settings => Debugging" and disabling the "Asset Cache"

That's brought my System Status page back, but I don't like the thought of not using a performance enhancement.

3

There have been many answers relating to this type of 'blank' page and most have been solved by ensuring the various paths set in Resources and Directories are correct.

Many questions on this have been tagged with angular so hopefully you will find the ones i am thinking of in the list at https://civicrm.stackexchange.com/questions/tagged/angular

  • 1
    Thanks, I'll have a look, but wouldn't incorrect resources and directories settings throw JS errors on other pages as well? I did have to resolve some directory settings during the upgrade, but their symptoms were very clear ("resource not loading" types of errors). My biggest problem at the moment is that I'm not seeing any types of errors AT ALL -- no JS console, no CiviCRM logs, no php, nothing. AND the system status reporting seems to be working in the popups. There's just missing code on the System Status page where there should be something. – minbori Sep 28 '17 at 16:29
  • 1
    This answer helped me as I had recently moved a site from domain.url to www.domain.url without updating my resource URLs in Civi, and my security settings had prevented loading the angular JS - may be of use to someone else! – termdark Feb 10 at 18:26
1

I'm getting the same error after upgrading to 4.7.25 from 4.7.16 on my WordPress installation. The disabling the Asset Cache workaround fixes it. I guess, for now, I'll just have to disable it whenever I need to check the system status.

  • 1
    I do think this might be an answer. It could that the asses cache contains an old version of the javascript files. What also might help is to clear the caches in CiviCRM by going to the following url: yoursite/civicrm/clearcache?reset=1 – Jaap Jansma - CiviCooP Nov 2 '17 at 8:43
  • I fixed it. I think it was caused by my use of the "Summary Fields" extension. I used the "Cleanup Caches and Update Paths" function. After I click "Update Paths" the "Summary Fields" extension was missing. I used the update extension function to restore it. After that, the system status worked.. – George Lozier Nov 5 '17 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.