0

I am using Civi 4.7.22 on WordPress 4.8.22 The Civi Tutorial says that Google no longer requires an API to use maps in civi. I am creating an event complete with an address location. All boxes to display the map are checked. Google Maps is select in Mapping and Geocoding. Yet the map is not displaying on the event page. Am I missing something?

Thank you.

4
  • Does the box for the map show up empty or not show up at all?
    – Laryn
    Sep 29, 2017 at 15:34
  • It does not show up at all. I see no sign of it from the front end.
    – fdarn
    Sep 29, 2017 at 16:26
  • Is your site live? If so can you post a link?
    – Laryn
    Sep 29, 2017 at 17:23
  • Yes it is live. narsol.org/civicrm/?page=CiviCRM&q=civicrm/event/…
    – fdarn
    Sep 29, 2017 at 17:26

2 Answers 2

0

It might be worth checking your browser console (right-click, inspect, console in Chrome) to see if the Google Maps API is returning a useful error / message when loading the event page.

1
  • Thank you. I tried that. I did not see any errors related to the map. It is just simply not showing up at all.
    – fdarn
    Sep 29, 2017 at 15:56
0

Problem solved. Latitude and Longitude must be enabled. If you attempt to create the event before latitude and longitude are enabled you will have to start over after it is enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.