I've installed the plugin successfully, but when I go visit the CiviCRM page in the backend, I get the following error:

Warning: require_once(CRM/Core/ClassLoader.php): failed to open stream: No such file or directory in /home/capitaleventscom/public_html/wp-content/uploads/civicrm/civicrm.settings.php on line 462

Fatal error: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/home/capitalevents/public_html/wp-content/plugins/civicrm/civicrm/:/home/capitalevents/public_html/wp-content/plugins/civicrm/civicrm//packages:.:/usr/local/php56/pear') in /home/capitaleventscom/public_html/wp-content/uploads/civicrm/civicrm.settings.php on line 462

I've tried but couldn't figure out anything. Any help will greatly be appreciated.

2 Answers 2


In the file civicrm.settings.php the variable $civicrm_root is defined. It should point to the directory where you installed the CiviCRM plugin. If it has the wrong value it causes the reported error.


Agreed with the @Kainuk answer. Here is what i did today to solve the same error. In your civicrm.settings.php if you have

require_once 'CRM/Core/ClassLoader.php';

Change it by adding "civicrm_root" variable

require_once $civicrm_root . '/CRM/Core/ClassLoader.php';

This is assuming that somewhere in that file, you have already set the "$civicrm_root" variable to point to your civiCRM install directory such as

$civicrm_root = '/var/www/html/drupal-root/vendor/civicrm/civicrm-core';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.