1

We have a webform set up to enable an individual to update an organisations details and then pay for the organisations annual membership. We are having an issue however where a user is reporting the following error.

I've tried to make payment for the [organisation] membership, but it tells me after putting my payment details in that it needs an email address to complete the transaction. There's no-where on this page to put that in!! There was on the previous page, and that part was completed.

The webform is set out as a two pages; updating details and membership payment, so I have truncated the screenshots to remove the non-relevant organisation updates:

This is the top of the webform linking the user to the organisation, in this case the *Station Administrator* user does have a permissioned relationship over the *Station* organisation

This is the top of the webform linking the user to the organisation, in this case the Station Administrator user does have a permissioned relationship over the Station organisation

This is the bottom of the webform with the payment page This is the bottom of the webform with the payment page

I have the organisation contribute webform set up identically as an individual membership we also run, so I can not see that there are any issues there(?) and I have used the individual payment page (directly through the contribute link though, not a webform) so that side of it worked for me.

Set-up wise, we are using D7.36 Civi4.4.14 and Stripe as our payment processor.

I would appreciate any thoughts you have, because I have tried everything to get this working and it does not want to be co-operative.

Edited 12 May 2015

I have been persevering with this taking @Coleman 's thoughts forwards. We have since had another report of payment failing (my previous member chose to pay using another method) and this is what I can glean from the CiviCRM:

  • When I masquerade as the user and go to the webform I can see the notice that their organisations membership has expired, so the relationships are being seen. I have also checked that the user is permissioned
  • When I go to the CiviContribute page directly while in masquerade there is nothing obvious that the Contribute page is recognising the link between the user and the organisation
  • When I go into our Stripe dashboard there is no record of any decline or failure; indeed the last successful transaction was my own which was around a month ago

I have also taken out the on behalf of organisation option that was in place as it was just loading a Reserved Profile that did not appear to be connecting to any existing information.

This is all getting very confusing now...

  • From your screenshot, I don't see a CiviCRM email field in the webform. You need to add an email field for contact 1 from the CiviCRM tab. – Coleman May 6 '15 at 18:32
  • Hmmm. I did add that, and it is the one on page two with the payment information. – Darren Whittenham-Gray May 6 '15 at 19:44
  • I see. Ok as an experiment, try adding a profile to the Civi contribution page (the one that's being embedded in the webform) which contains the email field. It won't be shown on the webform but might satisfy Civi. – Coleman May 6 '15 at 20:44
  • I am wondering if it would be more logical to set the confirmation page for the details update to be the CiviContribute page for the renewal. Then it will be forced to re-load the users details and cross them for the organisations. --- Maybe not as the Contribute Page does not appear to be recognising the connection between user and organisation. – Darren Whittenham-Gray May 7 '15 at 3:38
  • Make sure the relationship is "permissioned" in Civi. – Coleman May 7 '15 at 13:30
1

The final solution came from @Coleman and our developer resolved this by implementing a 1.9.1 branch of Stripe from GitHub alongside the dev Webform-civicrm ...

I would tick Colemans comments as the solution, but it won't let me.

0

For the problem with having the related org show up on the contribution page, if the relationship is not permissioned, and not of type "Employee of" then it will not work. There is currently work being done to fix this to work with other relationship types (although they still need to have the permission flag set in CiviCRM) See https://issues.civicrm.org/jira/browse/CRM-16490

  • So, because we have created the a custom relationship that is not employee of, it will not work? We have created the relationship of "Station Administrator for" which connects the relevant people to their organisation and made sure that they are permissioned. I assume now that this (and nothing within Eileen's permissions as ACLs 1.2 module will solve anything until the issue tracker fix is implemented? – Darren Whittenham-Gray May 14 '15 at 5:47
  • Thinking about it, is there a quick and dirty fix to create an identical "Employee of" for each "Station Administrator for"? I would read deep into this, but we are going to start losing money in the interim. – Darren Whittenham-Gray May 14 '15 at 6:01
0

An alternative to redirecting from a webform to a contribuion form would be to configure those settings directly in the webform. A webform can be set up to create and renew paid memberships if you configure both the "Contribution" and "Membership" sections of the webform on the CiviCRM tab.

For more information see the Memberships and Payments webform-civicrm instructions.

  • Right so.... that is already what I have in place. When I said in the original posts that I went directly to CiviContribute page that was just to see how the system reacted to narrow down the problems. Looking at the Memberships and Payments page I would suspect that it could be because we use Stripe as our payment processor? – Darren Whittenham-Gray May 17 '15 at 18:29
  • 1
    Could be. Stripe integration is quite new so be sure to use the bleeding edge of the stripe extension and the latest -dev version of webform-civicrm. – Coleman May 17 '15 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.