I have contacts belonging to different groups.

I made a first csv import successfully : I have all data of contacts and they are all in the same big group.

But then I tried to import them group by group with just their email address and the update option. The import seems to be successful. It mentions " Stratégie internet: One contact added to this existing group."

But when I go to group panel, the group has no new contact.

I tried many thing (import more than email for this 2nd import, change group visibility, use a new group, etc.) but it is still the same.

  • Generally if you are importing a csv and then planning on reimporting the same list to manipulate other info,, i would recommend adding a column to your csv for External ID, making a unique value for each record eg IMP-1 for the first and drag down to last row. Then when you reimport you can import against Ext ID and avoid any issues that might crop up with Matching Rules etc. That said, I am not too sure if it would fix your issue, hence not posting as an answer, since what you are describing should work fine assuming you are opting for UPDATE when you do your import (which you say you are)
    – petednz - fuzion
    Commented Oct 4, 2017 at 2:17
  • The other issue could be your Matching Rules. Do you actually see all the contacts you imported in CiviCRM?
    – petednz - fuzion
    Commented Oct 4, 2017 at 2:18

2 Answers 2


To bypass this problem, I use Yes/No custom field to import the data "Belonging to A group". Then I use an advanced search to select those contacts and add them to the A group.

  • Ah clever solution; yes this is a good way to handle Group imports Commented Oct 3, 2017 at 23:41

You haven't specified your CiviCRM version number, but there was recently a bug, CRM-20739, that caused this problem depending on your import settings. If you are using a version of CiviCRM less than 4.7.23, the solution is to upgrade.

  • Sorry I didn't see this ! We are on 4.7.22 ! Thanks a lot Commented Dec 13, 2017 at 9:58
  • I confirm ! Problem solved by updating to CiviCRM 4.7.29 Commented Mar 28, 2018 at 12:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.