1

before you send me to check already solved similar questions, this is not the same case.

Common problem is conflict with installed plugins -> disable/enabled them all, none, different order = nothing (I dont have jetpack, google dashboard, wp cards)

Another cause is template -> changed template, no difference but if I add Civi into blank Wordpress instalation it works.

Does anyone have same experience that it cannot be fixed with the "common" way ? And if yes did you manage to fix it ?

js error

  • By template, do you mean theme? – Iowa Boy Oct 15 '17 at 4:40
  • Yes :) Seems like it conflict with Civi by default. – tiouem Oct 16 '17 at 6:27
0

Try using one of the basic WordPress Themes like Twenty Seventeen or Twenty Sixteen. If it works with one of these themes, pick a new theme that you like.

You probably have to pick a theme from another company altogether. The theme designer probably has a base package that he/she uses and the problem will follow from theme to theme in their suite.

| improve this answer | |
  • Thank you for the comment, I contacted the theme creators and get answer that it is no way that the theme is causing this problem and when I change template to the basic one that you mentioned, error stay. On the other hand when I installed new wordpress on sub-domain with default theme and installed CiviCRM, it worked perfectly. – tiouem Oct 18 '17 at 12:05
  • What version of WP and Civi are you using? Is the install that you are having trouble with a new install or has it been functioning? Is the WP/Civi versions the same on your problem install as they are in your new test install? – Iowa Boy Oct 18 '17 at 14:29
  • WP 4.8.2 CIvi 4.7.24. It has never been fully functioning. Yes versions are same on the old one non-functioning as on the new fresh functioning. – tiouem Oct 19 '17 at 14:37
  • I am using WP 4.8.2 Civi 4.7.25. I get the exact same errors and cannot edit profiles on contribution pages. I had this for as long as I have been using Civi (2016). My theme creator told me that same thing but I have had developers look at it and it is a Civi/Theme conflict. Rather than paying for a patch, I just switch to the WP TwentySeverteen or TwentySixteen theme. Then go back to Manage Contribution > Profiles and set them to what I want. Go back to Themes and switch back to my normal theme. It screws up my site for a few minutes but is a workable fix. – Iowa Boy Oct 19 '17 at 17:58
  • 1
    The profile widget uses backbone.js and if your theme or a plugin also includes that library then they can conflict. There is an issue to make civi use backbone.js in no-conflict mode, but for now you can't use WordPress themes or plugins that include it – jackrabbithanna Nov 5 '17 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.