2

My client has asked me to disable Twilio handling replies from users - anyone know how this is done? i.e. outbound only, no inbound. The number I am renting says it can send/receive SMS - So I want it to send only, but can't see any settings for this. I removed the mo=1 parameter in Civi settings for Twilio but it made no difference. I'm on 4.7.21 and Drupal. Ideas?

2

The install instructions at https://wiki.civicrm.org/confluence/pages/viewpage.action?pageId=86213770#SettingupaSMSProviderforCiviSMS-twilio say

In Twilio account settings, go to Numbers and click on the number you want CiviCRM to "listen to". That will open configuration settings for that phone number. Under Messaging, change Request URL to http://yoursiteurl/civicrm/sms/callback?provider=org.civicrm.sms.twilio with HTTP POST

So if you remove that url it should stop posting inbound to CiviCRM.

  • Thanks - I was worried that this would kill outbound as well but it's the correct part to update - you have to blank the field and save. – Andy Clark Oct 9 '17 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.