0

I installed my Civicrm with the IP address of the server which turns out to be a "Bad Idea" (TM). Now when trying to enter various posts, such as membership details or new events I keep getting "logged out" (clicking save redirects to a login page for the IP-address).

I tried changing BASEURL in the civicrm.settings.php file, then clear all caches - but I still get this behaviour. Which is extremely annoying. How do I fix this?

2
  • Which CMS are you using? (Drupal, WordPress, Joomla!) Can you access the CMS correctly?
    – Aidan
    Oct 13, 2017 at 17:53
  • I'm using Joomla, and yes everything else seems to be working as supposed.
    – Martin
    Oct 13, 2017 at 19:40

1 Answer 1

1

Go to Administer > System Settings > Directories and Administer > System Settings > Resource URLs and make sure those show the new values. Depending on your CMS, you may need to make changes to its configuration as well.

3
  • Hmm, in Resource URLs I get CiviCRM Resource URL = [civicrm.root]/ While Directories only return a misrendered bare html page ...
    – Martin
    Oct 13, 2017 at 19:38
  • To be more specific, this is the content of Directories You may configure these upload directories using absolute paths or path variables. Path Variables [cms.root]
    – Martin
    Oct 14, 2017 at 2:07
  • If you click the help icon on those pages it will show the values of those variables for your system.
    – Aidan
    Oct 14, 2017 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.