Website is running 4.7.25 over Drupal. I was able to replicate this on this demo site, which is running at version 4.7.28, as well: http://dmaster.demo.civicrm.org/civicrm

Here are the steps to take to replicate the issue:

  1. Selected Search Builder
  2. Set extensive search criteria (like 12 of them)
  3. Set Select Records: to 'all'
  4. Select Export Contacts Action
  5. Search Builder Export Options (Step 2 of 3):
  6. Select Fields to Export checked
  7. Used Saved Field Mapping (note that I get the same problem regardless of my choice here)-- there were 17 fields in my map
  8. All other left at their default
  9. Clicked Continue
  10. Select Fields to Export (Step 3 of 3)
  11. Left at defaults
  12. Clicked Export
  13. Opened resulting downloaded csv.
  14. Columns were NOT as mapped; they seemed to be the fields shown on the search results, rather than what I had in field map.

I have several screen shots, but (sorry) cannot see how to post them here.

My workaround will be to select Primary Fields (80 fields) in the Export dialog, and just use the 17 columns I want in the resulting .csv. But, it would be cleaner/simpler for using in any automated processes if this worked correctly, so I thought I'd submit it if it's truly a bug. Unless someone here can point me to what I'm doing wrong?

Thanks!

  • in your testing did this problem only happen with a certain number of fields? or asked the other way round, have you proven the problem does not occur with a small set of fields? – petednz - fuzion Oct 17 '17 at 18:19
  • Good question, tried some additional scenarios today. I can see that the app exports the mapped fields and the search fields, which makes total sense. When I ran it with a lot more than 15 (combined mapped and search fields), only 15 columns came down. – vtmosaic Oct 17 '17 at 19:12
  • At the kind suggestion of Coleman Watts on JIRA Issues Queue, I am pasting a link to the JIRA issue I created on this question. issues.civicrm.org/jira/browse/CRM-21318?filter=-2 (I do now realize I should not have created that issue yet, but what's done is apparently done. Hope this helps mitigate the problems.) – vtmosaic Oct 17 '17 at 20:18

There is a JIRA issue for this 'oversight' and has been assigned to one of the Fuzion team to work on as part of a community 'pay-back/investment/pay-forward'.

  • Happy for someone else to take it on but i expect we can work on it in next few weeks. Ping me via this ticket, or jira, if we seem to be ignoring it – petednz - fuzion Oct 17 '17 at 23:37
  • We very much appreciate this. I will check back here and JIRA periodically. If I don' t see any activity after a few weeks, I will post a new comment to check in on progress. – vtmosaic Oct 18 '17 at 17:50

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.