2

In 4.7 - in my 4.7.24 as well as the demo - these buttons are no longer present in the CKEditor wysiwyg button toolbar.

4

It turns out this has a simple fix: add the 'Justify' plugin to Civicrm.

Go to the CKEditor config screen: Administer > Customise data and screens > Display preferences > CKEditor config

Then add the Justify plugin.

A new toolbar group will appear in the 'paragraph' section, which you can then move around as you'd like.

Then save your settings...

In my installation, for some reason something is hampering the UI from working properly. If that's the case, you can still call the plugin by directly editing the config file: (in our drupal 7.56 installation) sites/default/files/civicrm/persist/crm-ckeditor-default.js

and ensure you add the justify plugin to lines like:

{ name: 'paragraph', groups: [ 'list', 'indent', 'blocks', 'align', 'bidi', 'paragraph', 'justify' ] },

and

config.extraPlugins = "justify,showblocks";

If you're editing this file directly you have to be very aware that it will be over-written if anyone saves the CKEditor settings using the UI as above.

Hope this is helpful to others out there mystified by the lack of these buttons!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.