I can't browse images to include in CKEditor when using CiviMail. When I click the browse button in the image window, the following pops up


and get "500 - Internal Server Error" with suggestions that file permissions are not correct. Don't know what to check specifically, but all the resource URLS and directories are defaults and file permissions look generally OK.

I have WordPress 4.8.2 and CiviCRM 4.7.25. There are one or two similar posts about not being able to browse files, but none quite the same and answers not very specific about what what files to check permissions of. Nothing in the ConfigAndLog directory. Works fine on the demo WordPress site, but of course can't see permissions etc. I'm stuck!

  • Have you tried uploading an image through CKEditor in CiviMail?
    – Graham
    Oct 27, 2017 at 9:26
  • I have tried an upload and when I press "send it to the server" it goes to a screen still with the "send it to the server button" and an odd scroll bar across the top. Otherwise no meaningful content. If I press "OK" then I get a message "Image source URL is missing". No doubt related.
    – Mick Kahn
    Oct 27, 2017 at 16:25
  • Also, I can't try it out on my test site because of another problem that means I don't see CKEditor at all there. See civicrm.stackexchange.com/questions/20888/…. That means I can't mess around with Resource URL or directory settings as that might break something else on the live site.
    – Mick Kahn
    Oct 27, 2017 at 16:30
  • I've now found some logs with more details and get "[2017-11-03 08:17:41]: error: directory is writable by others: (/home/downham4/public_html/wp-content/plugins/civicrm/civicrm/packages/kcfinder)" but any attempts to reduce the permissions for the directory either have no effect or result in a 403 error which is permissions to low!
    – Mick Kahn
    Nov 3, 2017 at 8:33
  • maybe its about ownership rather then permissions? (don;t know, just exploring)
    – Graham
    Nov 3, 2017 at 15:34

1 Answer 1


I forgot to post an answer before, but am prompted to do so as someone has a similar problem.

I needed to set directory 755 and files 644 for wp-content/plugins/civicrm/civicrm/packages/kcfinder because the WP distribution didn't set permissions that worked in my hosting environment.

But since CiviCRM 5.2.2 this wasn't necessary.

  • Thanks. I just tried this (set directory 755) for /civicrm/packages/kcfinder in Drupal 7 / CiviCRM 5.57.0 and it appears to have done the job after I deleted the session cookie in my browser and then logged in again. Feb 2, 2023 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.