0

I just created a new contribution page in Civi and made sure it was active. When I go to create a new wordpress page and try to insert it I have no options to choose from when I click on the CiviCRM button. The only thing it shows is the dashboard options. How do I get my Civi Contribution form into a wordpress page? Is there some sort of a setting I am missing to get active contribution pages to show up as an option to choose from?

1
  1. Disable all of your plugins (except CiviCRM) and try it again. If you can now see the Civi options, you have a couple of options: a. Set up your page, reactivate your plugins and go on with life, b. Reactivate the plugins one by one to see which is the issue.

If that does not work:

  1. Switch to a WP basic theme like Twenty Seventeen or Twenty Sixteen and try the page create again. If you can see the Civi options, I would setup the page, switch back to your theme of choice. Just switch to a basic theme when you need to see the options and then back to your theme for usage.

If you do not want to mess with either above,

  1. Under Contributions > Manage Contribution Pages > Select the page you want > Links > Live. This will give you a link that ends in id=# Below is an example of Civi shortcode. Replace the 2 in the shortcode below with the id# from your live link and paste it to your WP page. [civicrm component="contribution" id="2" mode="live" hijack="0"]
0

Drag the Pop up window over. Usually the drop down is rendered on a lower Z axis than the pop up.

The Select2 is being broken by a plugin or the theme. Usually it is a Fusion theme or a page building plugin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.