2

I think i must be missing something.

When I go to Option Groups /civicrm/admin/options?reset=1

and choose Language

/civicrm/admin/options?gid=75&reset=1

i see no value listed as Default, and no option when I click 'edit' on an option to set it as Default, yet if i look in the DB for values where option_group_id = 75 it shows en_US as default.

I set this to the desired value but where I am being blind in terms of doing this via the UI?

  • I have the same problem trying to set UK english. If anybody has an answer please let us know. – Simon Walden Oct 11 at 12:53
  • my sense is this is a bug/new requirement and someone needs to offer a patch. if you want us to look in to this I would be happy to offer 50% discount since it hit us too though clearly didn't cause enough of an itch at the time for us to scratch it. – petednz - fuzion Oct 15 at 20:58
1

We can set default language in localization settings - /civicrm/admin/setting/localization?reset=1

enter image description here

But, if I change that, the default value in the options_value table doesn't change, so not sure if it meets your requirement.

  • i think that is more the language setting for the interface, not the 'preferred language' of the contact. – petednz - fuzion Oct 30 '17 at 7:28
  • 2
    and i don't see why i should need to download a 'translation' purely to avoid all the contacts being tagged as 'preferred language = en_US' because I assure you, it is not the preferred language in much of the world. – petednz - fuzion Oct 30 '17 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.