0

Probably a Drupal issue, but you never know :

I am running Drupal 7.56 / Civi 4.7.20

I have been using Views extensively for some months now. I want now to create custom pdf pages from some Views.

I have installed jQuery_update, then Views PDF Display Module, then copied fpdi and tcpdf libraries into the Libraries folder (via FTP).

Now, when I want to add a PDF Page to a View, I get the following error message : Fatal error: require_once(): Failed opening required 'sites/all/libraries/fpdi/fpdi2tcpdf_bridge.php' (include_path='/home/my_hostname/www/www/sites/paroisse/civi_extensions/nz.co.fuzion.cmcic-master/:/home/my_hostname/www/www/sites/paroisse/civi_extensions/nz.co.fuzion.extendedreport/:/home/my_hostname/www/www/sites/paroisse/civi_extensions/org.civicrm.sms.twilio/:/home/my_hostname/www/www/sites/paroisse/civi_extensions/com.drastikbydesign.stripe/packages/:/home/my_hostname/www/www/sites/paroisse/civi_extensions/com.drastikbydesign.stripe/:/home/my_hostname/www/www/sites/default/fpdf:.:/home/my_hostname/www/www/sites/all/modules/civicrm:/home/my_hostname/www/www/sites/all/modules/civicrm/packages:.:/home/my_hostname/www/www/sites/all/modules/civicrm:/home/my_hostname/www/www/sites/all/modules/civicrm/packages:/home/my_hostname/www/www/sites/all/modules/civicrm/vendor/tecnickcom:/home/my_hostname/www/www/sites/all/modules/civicrm/vendor/phpseclib/phpseclib/phpseclib:/home/my_hostname/www/www/sites/all/modules in /home/my_hostname/www/www/sites/all/modules/views_pdf/views_pdf_template.php on line 22

I suspect that this is due to a bad installation (btw, the fdpi library contains no fpdi2tcpdf_bridge.php), but find no clear and up-to-date installation tutorial.

I am not a programmer (just able to edit and ftp a file if necessary)

Any help is welcome.

1

I went back to fpdi-1.6.2, and the error disappeared (the internal fpdi folder content has completely changed between the two versions).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.