1

I've recently migrated a site to another host and pretty much everything is working except that when I go to /civicrm, the dashlets on the dashboard all show Access Denied and a login form. They are being provided by CiviReport according to their respective breadcrumbs.

In addition, I noticed that I could not disable CiviReport or any of the other CiviCRM Components. When I click Save on that page, it just bumps me back to /civicrm/admin with no error message. Going back into civicrm/admin/setting/component just shows the modules still enabled.

I'm still a CiviCRM noob, so it could be something simple.

  • Check your civicrm.settings.php file. I suspect your baseurl is incorrect. What CMS are you using? Also read through this wiki.civicrm.org/confluence/display/CRMDOC42/… – Tommy B Nov 2 '17 at 20:38
  • ... or the latest version at docs.civicrm.org/sysadmin/en/latest/misc/switch-servers – Aidan Nov 2 '17 at 23:52
  • Tommy B > I've double-checked my base URL and I can see the data in CiviCRM. The CMS in this case is Drupal. I'm also having the same problem on a different site with Wordpress, too, though. I followed the same steps as in that guide, but I didn't actually disable CiviCRM before dumping the DB. Do you think that could cause it? – user5249 Nov 3 '17 at 15:45
3

Check your civicrm.settings.php, and make sure that the CIVICRM_BASE_URL matches your site url.

My site was redirecting http://domain.com to http://www.domain.com, but civicrm.settings.php had the version without the www, which was screwing things up.

1

Check that you are using https://... or http://... consistently and not mixing them. (Preferably https!)

I have seen that where you have a mismatch between the URL you are logging in with and the resource URL's (configured at Administer > System Settings > Resource URL's). For example, if your Resource URL's are https://... but you log in as http://

I usually redirect any http://... requests to https://... in .htaccess

  • I do have redirection set up and the content in the widgets are being addressed by https. Also, I have the resource URLs set and they look right to me. Are they supposed to be in the format: domain.com/sites/all/modules/civicrm ? – user5249 Nov 3 '17 at 15:50
  • That was the right format, except that it should include https:// at the front. Newer installations use [civicrm.root]. If you go to Administer > System Settings > Resource URLs then click the help icon at the end of the help box then it will show you the values in use on your site. – Aidan Nov 4 '17 at 13:18
  • Also, you could open the Network tab in your browser to confirm the URLs being requested. Eg for Firefox, go to Tools > Web Developer > Network and reload your dashboard. – Aidan Nov 4 '17 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.