0

I recently installed Civicrm on AWS. App works great! However, when I creat a load balancer with a SSL certificate and point the Domain towards the LB, I get a 503 page. If I don't use SSL, everything works fine.

What am I missing?

1

You should look at log the load balancer. the 503 might be generated there (ie. the LB can't reach the backend) or it might be that the LB can reach the real servers hosting civi, but they can't process the request

Assuming you trust amazon (a big assumption), you might want to say that the https LB can talk to an unsecure civi server (via http).

Otherwise if you want to be more secure and don't trust amazon, you might need to configure your civicrm server so they handle https too.

0

It's hard to say without knowing more about your configuration - but the first thing to check is that your BASE_URL setting in civicrm.settings.php is set to HTTPS.

Besides that, I'd check the web server logs (Apache/nginx/etc.) on the CiviCRM host. It's pretty common to get a 503 from a reverse proxy when it can't connect to the backend server. Troubleshooting that is out of scope for this Stack Exchange, but it will tell you whether this problem is CiviCRM-specific or not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.