We recently upgraded to 4.6.2 but CiviMail does not present the Joomla Default WYSIWYG editor like it did in previous versions but only displays the CKEditor.

We are using JCE editor and it's ability to more easily upload and manage images worked well.

Also, the CKEditor is throwing a 404 error when I try to 'Browse Server' for an image, (Send it to the server doesn't work either).

This all means that it is a bit difficult for users to add images to mailings.

Is there any way of getting the new civimail to use the default CMS WYSYWIG like before?



1 Answer 1


My understanding is that the new CiviMail approach necessitated disabling the "use CMS default" option for WYSIWYG. The new preferred approach is CiviCRM extensions to implement other WYSIWYG editors - it took about an hour to create the first WYSIWYG extension for CiviCRM, and others can build even quicker, using that extension as a guide. You can find it here: https://github.com/relldoesphp/com.aghstrategies.tinymce

  • Great, thanks for the info, could you shed any light on why the 'Browse Server' or upload features within the default editor isn't working?
    – Dave
    Commented May 7, 2015 at 16:23
  • If I saw the URL that was causing the 404 error I'd have more of a clue - but I would check Administer menu > System Settings > Directories (the first three settings) and **Administer menu > System Settings > Resource URLs (the Image Upload URL). Confirm that these settings are a) all set, b) the corresponding directories exist on the server, and c) their permissions are correctly set (the web server user should be able to read/write) Commented May 7, 2015 at 21:08
  • WYSIWYG Editor setting is defunct? Can't change to even no editor. CKeditor is now appending to <img> tag "src=" class to "dfsrc=". Anyone else experiencing this?
    – BruceW
    Commented May 20, 2015 at 1:14
  • Tim Otten's patch that will be released with 4.6.3 fixes this problem, at least, it did for me.
    – BruceW
    Commented May 20, 2015 at 3:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.